{
 "version": "https://jsonfeed.org/version/1.1",
 "title": "ollama: all CVE events",
 "home_page_url": "https://patchwire.jonathanross.dev/products/ollama--ollama/",
 "feed_url": "https://patchwire.jonathanross.dev/feeds/products/ollama--ollama/all.json",
 "authors": [
  {
   "name": "Patchwire"
  }
 ],
 "language": "en",
 "items": [
  {
   "id": "tag:patchwire.jonathanross.dev,2026:CVE-2026-103663/disclosed",
   "url": "https://patchwire.jonathanross.dev/cve/CVE-2026-103663/",
   "title": "CVE-2026-103663 · ollama · disclosed",
   "content_text": "Ollama is vulnerable to path traversal in the `/api/pull` endpoint due to insufficient validation of layer digests by the `digestToPath` function. An unauthenticated remote attacker can specify a path traversal sequence as a layer digest, causing a malicious binary to be written outside the model store. \n\nCritically if the server process has write access to `/usr/lib/ollama` (the default in most Ollama Docker images), an attacker can write the malicious file to that directory. On the next server restart, the file is loaded and executed, resulting in remote code execution as root.\n\n\nThis issue was fixed in version 0.35.0.",
   "date_published": "2026-10-08T13:19:04Z"
  },
  {
   "id": "tag:patchwire.jonathanross.dev,2026:CVE-2026-102697/disclosed",
   "url": "https://patchwire.jonathanross.dev/cve/CVE-2026-102697/",
   "title": "CVE-2026-102697 · ollama · disclosed",
   "content_text": "Ollama versions 0.14.0 before 0.31.2 contain an incorrect authorization vulnerability in the experimental agent mode Bash tool approval mechanism that fails to properly parse shell syntax. Attackers who can influence model output through prompt injection can execute additional shell commands by appending control operators like semicolons or logical operators to approved commands, bypassing the session approval requirement.",
   "date_published": "2026-09-29T16:46:08Z"
  }
 ]
}
