CVE-2026-96292
Fixed in a distro release EPSS <1%CVSS 8.2
Inefficient regular expression complexity, Inefficient Algorithmic Complexity vulnerability in Apache Thrift Lua bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Products: Apache Software Foundation Apache Thrift
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | thrift | no fix |
| Debian 13 | thrift | no fix |
| Debian 14 | thrift | no fix |
| Red Hat hummingbird 1 | perl-thrift | 0:0.25.0-0.1.hum1 |
| Red Hat hummingbird 1 | python3-thrift | 0:0.25.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift | 0:0.25.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift-devel | 0:0.25.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift-glib | 0:0.25.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift-qt | 0:0.25.0-0.1.hum1 |
| Ubuntu 20.04 LTS | thrift | no fix |
| Ubuntu 22.04 LTS | thrift | no fix |
| Ubuntu 24.04 LTS | thrift | no fix |
| Ubuntu 26.04 LTS | thrift | no fix |
| Ubuntu 26.10 | thrift | no fix |
| openSUSE Tumbleweed | thrift | 0.25.0-1.1 |