CVE-2026-9504
Fixed in a distro release EPSS <1%CVSS 3.3
A weakness has been identified in GNU LibreDWG up to 0.14. Affected is the function bit_convert_TU of the file programs/dwggrep.c of the component Dwggrep Utility. This manipulation causes out-of-bounds read. The attack needs to be launched locally. The exploit has been made available to the public and could be used for attacks. Patch name: be996bf2178a40e98720f18c2414815d244413db. Applying a patch is the recommended action to fix this issue.
Products: gnu libredwg
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Leap 16.0 | libredwg | 0.14.8413-bp160.1.1 |
| openSUSE Tumbleweed | libredwg | 0.13.4.8200-1.1 |