CVE-2026-94637
Fixed in a distro release EPSS <1%CVSS 8.2
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Products: Apache Software Foundation Apache Thrift
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | milvus-2.5 | 2.5.27-r38 |
| Chainguard | milvus-2.6 | 2.6.25-r9 |
| Chainguard | milvus-3.0 | 3.0.3-r4 |
| Chainguard | opentelemetry-collector-contrib | 0.163.0-r0 |
| Chainguard | opentelemetry-collector-contrib-fips | 0.163.0-r0 |
| Debian 12 | thrift | no fix |
| Debian 13 | thrift | no fix |
| Debian 14 | thrift | no fix |
| Ubuntu 20.04 LTS | thrift | no fix |
| Ubuntu 22.04 LTS | thrift | no fix |
| Ubuntu 24.04 LTS | thrift | no fix |
| Ubuntu 26.04 LTS | thrift | no fix |
| Ubuntu 26.10 | thrift | no fix |
| Wolfi | opentelemetry-collector-contrib | 0.163.0-r0 |