CVE-2026-94056
Fixed in a distro release EPSS <1%CVSS 7.5
Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, allows attackers to read certain uninitialized data from stack memory.
Products: exim
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | exim4 | no fix |
| Debian 13 | exim4 | 4.98.2-1+deb13u5 |
| Debian 14 | exim4 | 4.100.1-1 |
| Ubuntu 22.04 LTS | exim4 | 4.95-4ubuntu2.12 |
| Ubuntu 24.04 LTS | exim4 | 4.97-4ubuntu4.8 |
| Ubuntu 26.04 LTS | exim4 | 4.99.1-1ubuntu1.5 |
| Ubuntu Pro 14.04 LTS | exim4 | no fix |
| Ubuntu Pro 16.04 LTS | exim4 | no fix |
| Ubuntu Pro 18.04 LTS | exim4 | no fix |
| Ubuntu Pro 20.04 LTS | exim4 | no fix |