CVE-2026-93989
Fixed in a distro release EPSS <1%CVSS 3.1
vLLM through 0.29.0 fails to properly validate bad_words token indices against the model's generation output width in SamplingParams.update_from_tokenizer(). Attackers can supply out-of-bounds token indices that corrupt logits memory of concurrent requests, causing different in-flight HTTP requests to return incorrect tokens.
Products: vllm-project vllm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | vllm | 0.30.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE Tumbleweed | python-vllm | 0.30.0-1.1 |