CVE-2026-93894
Fixed in a distro release EPSS <1%CVSS 2.3
In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to make the child process segfault or assert, and then restart. Effectively exploiting this vulnerability requires prior knowledge about the VCL in use and the ability to craft a request that contains a string that is long enough to fill the remaining workspace at the call site while staying under the different request size limits (http_req_size, http_req_hdr_len, etc.).
Products: Vinyl-Cache Vinyl Cache, varnish-software varnish_cache
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | varnish | no fix |
| Debian 13 | varnish | 7.7.0-3+deb13u2 |
| Debian 14 | vinyl-cache | no fix |
| Ubuntu 14.04 LTS | varnish | no fix |
| Ubuntu 24.04 LTS | varnish | no fix |
| Ubuntu 26.04 LTS | varnish | no fix |
| Ubuntu 26.10 | varnish | no fix |
| Ubuntu 26.10 | vinyl-cache | no fix |
| Ubuntu Pro 16.04 LTS | varnish | no fix |
| Ubuntu Pro 18.04 LTS | varnish | no fix |
| Ubuntu Pro 20.04 LTS | varnish | no fix |
| Ubuntu Pro 22.04 LTS | varnish | no fix |