Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-92951

Fixed upstream EPSS <1%CVSS 9.9

vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.

Published 2026-09-17 · CVE record · OSV

Products: patriksimek vm2

Fixed upstream

EcosystemPackageFixed in
npmvm23.11.7