Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-92946

Fixed upstream EPSS <1%CVSS 10.0

vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules. Sandboxed code can require vm2's own package, instantiate an unrestricted NodeVM instance, and execute arbitrary host OS commands via child_process.

Published 2026-09-17 · CVE record · OSV

Products: patriksimek vm2

Fixed upstream

EcosystemPackageFixed in
npmvm23.11.7