CVE-2026-92596
Fixed in a distro release EPSS <1%CVSS 7.5
Nodemailer before 9.1.0 contains a quadratic time complexity vulnerability in the addressparser component that allows remote attackers to cause denial of service by supplying a crafted comma-separated address list. Attackers can send a single email with a large number of addresses to block the Node.js event loop for extended periods, consuming 100% CPU and freezing the process.
Products: nodemailer
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | nodemailer | 9.1.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | node-nodemailer | no fix |
| Debian 13 | node-nodemailer | no fix |
| Debian 14 | node-nodemailer | 10.0.0+~8.0.1-1 |
| Ubuntu 20.04 LTS | node-nodemailer | no fix |
| Ubuntu 22.04 LTS | node-nodemailer | no fix |
| Ubuntu 24.04 LTS | node-nodemailer | no fix |
| Ubuntu 26.04 LTS | node-nodemailer | no fix |
| Ubuntu 26.10 | node-nodemailer | no fix |