CVE-2026-91955
Fixed in a distro release EPSS <1%CVSS 7.5
FreeRDP before 3.31.0 fails to validate client-supplied DesktopWidth and DesktopHeight values during GCC negotiation, allowing remote attackers to crash the server. Attackers can send crafted RDP packets with zero or oversized dimensions to trigger division-by-zero or assertion failures in multifragment update capability calculations, terminating the server process.
Products: FreeRDP
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | freerdp2 | no fix |
| Debian 13 | freerdp3 | no fix |
| Debian 14 | freerdp3 | 3.31.0+dfsg-1 |
| Ubuntu 16.04 LTS | freerdp | no fix |
| Ubuntu 18.04 LTS | freerdp | no fix |
| Ubuntu 22.04 LTS | freerdp2 | no fix |
| Ubuntu 24.04 LTS | freerdp3 | 3.31.0+dfsg-0ubuntu0.24.04.1 |
| Ubuntu 26.04 LTS | freerdp3 | 3.31.0+dfsg-0ubuntu0.26.04.1 |
| Ubuntu Pro 18.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 20.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 24.04 LTS | freerdp2 | no fix |