CVE-2026-91945
Fixed in a distro release EPSS <1%CVSS 6.5
FreeRDP versions before 3.31.0 contain an out-of-bounds read vulnerability in smartcard response decoders that fail to validate ATR length fields against fixed inline arrays. Authenticated RDP clients can send oversized ATR lengths in PAKID_CORE_DEVICE_IOCOMPLETION responses to trigger reads past stack or heap objects, causing process termination.
Products: FreeRDP
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Amazon Linux 2023 | freerdp | 2:3.31.0-1.amzn2023 |
| Amazon Linux 2023 | freerdp-devel | 2:3.31.0-1.amzn2023 |
| Amazon Linux 2023 | freerdp-libs | 2:3.31.0-1.amzn2023 |
| Amazon Linux 2023 | freerdp-server | 2:3.31.0-1.amzn2023 |
| Amazon Linux 2023 | libwinpr | 2:3.31.0-1.amzn2023 |
| Amazon Linux 2023 | libwinpr-devel | 2:3.31.0-1.amzn2023 |
| Debian 14 | freerdp3 | 3.31.0+dfsg-1 |
| Ubuntu 16.04 LTS | freerdp | no fix |
| Ubuntu 18.04 LTS | freerdp | no fix |
| Ubuntu 22.04 LTS | freerdp2 | no fix |
| Ubuntu 24.04 LTS | freerdp3 | 3.31.0+dfsg-0ubuntu0.24.04.1 |
| Ubuntu 26.04 LTS | freerdp3 | 3.31.0+dfsg-0ubuntu0.26.04.1 |
| Ubuntu Pro 18.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 20.04 LTS | freerdp2 | no fix |
| Ubuntu Pro 24.04 LTS | freerdp2 | no fix |