CVE-2026-8823
Fixed upstream EPSS <1%CVSS 3.8
Mattermost versions 11.7.x <= 11.7.0, 10.11.x <= 10.11.17 fail to validate bot targets when demoting users to guests which allows a lower-privileged administrator to degrade arbitrary bot accounts via the standard demote-user API.. Mattermost Advisory ID: MMSA-2026-00669
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.7.1 |
| Go | github.com/mattermost/mattermost-server | 10.11.18 |
| Go | github.com/mattermost/mattermost-server | 10.11.18+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.7.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260518160100-9bd77d3fc4d2 |