CVE-2026-88041
Fixed in a distro release EPSS <1%
Incomplete cleanup vulnerability in Apache Tomcat allowed an trailer information from a previous request to leak into a subsequent request. This issue affects Apache Tomcat: from 11.0.0-M23 through 11.0.26, from 10.1.27 through 10.1.60, from 9.0.92 through 9.0.122. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
Products: Apache Software Foundation Apache Tomcat
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | tomcat10 | no fix |
| Debian 12 | tomcat9 | 9.0.70-2 |
| Debian 13 | tomcat10 | no fix |
| Debian 13 | tomcat11 | no fix |
| Debian 13 | tomcat9 | 9.0.70-2 |
| Debian 14 | tomcat10 | no fix |
| Debian 14 | tomcat11 | no fix |
| Debian 14 | tomcat9 | 9.0.70-2 |
| Ubuntu 24.04 LTS | tomcat10 | no fix |
| Ubuntu 24.04 LTS | tomcat9 | no fix |
| Ubuntu 26.04 LTS | tomcat10 | no fix |
| Ubuntu 26.04 LTS | tomcat11 | no fix |
| Ubuntu 26.04 LTS | tomcat9 | no fix |
| Ubuntu 26.10 | tomcat10 | no fix |
| Ubuntu 26.10 | tomcat11 | no fix |
| Ubuntu 26.10 | tomcat9 | no fix |
| Ubuntu Pro 14.04 LTS | tomcat6 | no fix |
| Ubuntu Pro 14.04 LTS | tomcat7 | no fix |
| Ubuntu Pro 16.04 LTS | tomcat7 | no fix |
| Ubuntu Pro 16.04 LTS | tomcat8 | no fix |
| Ubuntu Pro 18.04 LTS | tomcat8 | no fix |
| Ubuntu Pro 18.04 LTS | tomcat9 | no fix |
| Ubuntu Pro 20.04 LTS | tomcat9 | no fix |
| Ubuntu Pro 22.04 LTS | tomcat9 | no fix |
| openSUSE Tumbleweed | tomcat | 9.0.123-1.1 |
| openSUSE Tumbleweed | tomcat10 | 10.1.61-1.1 |
| openSUSE Tumbleweed | tomcat11 | 11.0.27-1.1 |