CVE-2026-84471
Fixed in a distro release EPSS <1%CVSS 7.2
The fix for CVE-2026-12996 was incomplete. A use-after-free in OpenVPN 2.6.0 through 2.6.22 and 2.7_alpha1 through 2.7.7 allows remote authenticated peers to potentially cause a denial of service or leak memory via crafted packets during TLS session promotion or expiry.
Products: OpenVPN
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | openvpn | no fix |
| Debian 13 | openvpn | no fix |
| Debian 14 | openvpn | 2.7.7-1 |
| Ubuntu 20.04 LTS | openvpn | no fix |
| Ubuntu 22.04 LTS | openvpn | 2.5.11-0ubuntu0.22.04.5 |
| Ubuntu 24.04 LTS | openvpn | 2.6.19-0ubuntu0.24.04.4 |
| Ubuntu 26.04 LTS | openvpn | 2.7.0-1ubuntu1.3 |
| Ubuntu Pro 14.04 LTS | openvpn | no fix |
| Ubuntu Pro 16.04 LTS | openvpn | no fix |
| Ubuntu Pro 18.04 LTS | openvpn | no fix |