CVE-2026-8212
Fixed in a distro release EPSS <1%CVSS 5.3
A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.
Products: osgeo gdal
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | gdal | 3.13.0RC1 |
| PyPI | gdal | no fix |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | py3.10-gdal | 3.13.0-r0 |
| Chainguard | py3.10-gdal | 3.13.1-r0 |
| Chainguard | py3.10-gdal-3.8 | 3.8.5-r16 |
| Chainguard | py3.11-gdal | 3.13.1-r0 |
| Chainguard | py3.11-gdal-3.8 | 3.8.5-r16 |
| Chainguard | py3.12-gdal | 3.13.1-r0 |
| Chainguard | py3.12-gdal | 3.13.0-r0 |
| Chainguard | py3.12-gdal-3.8 | 3.8.5-r16 |
| Chainguard | py3.13-gdal | 3.13.1-r0 |
| Chainguard | py3.13-gdal-3.8 | 3.8.5-r16 |
| Debian 12 | gdal | no fix |
| Debian 13 | gdal | no fix |
| Debian 14 | gdal | 3.13.0+dfsg-1 |
| Ubuntu 25.10 | gdal | no fix |
| Ubuntu Pro 14.04 LTS | gdal | 1.10.1+dfsg-5ubuntu1+esm3 |
| Ubuntu Pro 16.04 LTS | gdal | 1.11.3+dfsg-3ubuntu0.1~esm2 |
| Ubuntu Pro 18.04 LTS | gdal | 2.2.3+dfsg-2ubuntu0.1~esm1 |
| Ubuntu Pro 20.04 LTS | gdal | 3.0.4+dfsg-1ubuntu0.1~esm1 |
| Ubuntu Pro 22.04 LTS | gdal | 3.4.1+dfsg-1ubuntu0.1~esm1 |
| Ubuntu Pro 24.04 LTS | gdal | 3.8.4+dfsg-3ubuntu3+esm1 |
| Ubuntu Pro 26.04 LTS | gdal | 3.12.2+dfsg-1ubuntu0.1~esm1 |
| Wolfi | py3.10-gdal | 3.13.1-r0 |
| Wolfi | py3.10-gdal | 3.13.0-r0 |
| Wolfi | py3.11-gdal | 3.13.1-r0 |
| Wolfi | py3.12-gdal | 3.13.1-r0 |
| Wolfi | py3.12-gdal | 3.13.0-r0 |
| Wolfi | py3.13-gdal | 3.13.1-r0 |