CVE-2026-8147
Fixed in a distro release EPSS <1%CVSS 8.1
In MLflow versions prior to 3.14.0, when running with authentication enabled, the trace API endpoints lack proper authorization validators. This allows any authenticated user to bypass experiment-level authorization controls on all trace operations, including reading, deleting, and modifying traces on experiments they do not have permission to access. The issue arises from the `_before_request` handler, which does not register authorization validators for trace endpoints, resulting in requests proceeding without validation. This vulnerability can expose sensitive data, destroy audit logs, and allow unauthorized modifications.
Products: mlflow/mlflow
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | mlflow | 3.13.0rc0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | mlflow | 3.16.0-r0 |
| Wolfi | mlflow | 3.16.0-r0 |