CVE-2026-8086
Fixed in a distro release EPSS <1%CVSS 5.3
A vulnerability was identified in OSGeo gdal up to 3.13.0dev-4. This issue affects the function SWnentries of the file frmts/hdf4/hdf-eos/SWapi.c. Such manipulation of the argument DimensionName leads to heap-based buffer overflow. The attack must be carried out locally. The exploit is publicly available and might be used. Upgrading to version 3.12.4RC1 is capable of addressing this issue. The name of the patch is 9491e794f1757f08063ea2f7a274ad2994afa636. It is advisable to upgrade the affected component.
Products: osgeo gdal
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | gdal | 3.13.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | gdal | no fix |
| Debian 13 | gdal | no fix |
| Debian 14 | gdal | 3.13.0+dfsg-1 |
| Ubuntu 25.10 | gdal | no fix |
| Ubuntu Pro 14.04 LTS | gdal | 1.10.1+dfsg-5ubuntu1+esm3 |
| Ubuntu Pro 16.04 LTS | gdal | 1.11.3+dfsg-3ubuntu0.1~esm2 |
| Ubuntu Pro 18.04 LTS | gdal | 2.2.3+dfsg-2ubuntu0.1~esm1 |
| Ubuntu Pro 20.04 LTS | gdal | 3.0.4+dfsg-1ubuntu0.1~esm1 |
| Ubuntu Pro 22.04 LTS | gdal | 3.4.1+dfsg-1ubuntu0.1~esm1 |
| Ubuntu Pro 24.04 LTS | gdal | 3.8.4+dfsg-3ubuntu3+esm1 |
| Ubuntu Pro 26.04 LTS | gdal | 3.12.2+dfsg-1ubuntu0.1~esm1 |