CVE-2026-8084
Fixed in a distro release EPSS <1%CVSS 3.3
A vulnerability was determined in OSGeo gdal up to 3.13.0dev-4. This vulnerability affects the function memmove of the file frmts/hdf4/hdf-eos/SWapi.c of the component HDF-EOS Grid File Handler. This manipulation causes out-of-bounds read. The attack is restricted to local execution. The exploit has been publicly disclosed and may be utilized. Upgrading to version 3.13.0RC1 is able to resolve this issue. Patch name: a791f70f8eaec540974ec989ca6fb00266b7646c. Upgrading the affected component is advised.
Products: osgeo gdal
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | gdal | 3.13.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | gdal | no fix |
| Debian 13 | gdal | no fix |
| Debian 14 | gdal | 3.13.0+dfsg-1 |
| Ubuntu 25.10 | gdal | no fix |
| Ubuntu Pro 14.04 LTS | gdal | 1.10.1+dfsg-5ubuntu1+esm3 |
| Ubuntu Pro 16.04 LTS | gdal | 1.11.3+dfsg-3ubuntu0.1~esm2 |
| Ubuntu Pro 18.04 LTS | gdal | 2.2.3+dfsg-2ubuntu0.1~esm1 |
| Ubuntu Pro 20.04 LTS | gdal | 3.0.4+dfsg-1ubuntu0.1~esm1 |
| Ubuntu Pro 22.04 LTS | gdal | 3.4.1+dfsg-1ubuntu0.1~esm1 |
| Ubuntu Pro 24.04 LTS | gdal | 3.8.4+dfsg-3ubuntu3+esm1 |
| Ubuntu Pro 26.04 LTS | gdal | 3.12.2+dfsg-1ubuntu0.1~esm1 |