CVE-2026-80205
Fixed in a distro release EPSS <1%CVSS 7.5
NLTK versions before 3.10.0 contain a regular expression denial of service vulnerability in Text.findall() and TokenSearcher.findall() methods that accept user-supplied regular expressions without validation or timeout. Attackers can supply crafted regex patterns that cause catastrophic backtracking, resulting in indefinite CPU saturation and denial of service to all users of the Python process.
Products: nltk
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | nltk | 3.10.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | nltk | no fix |
| Debian 13 | nltk | no fix |
| Debian 14 | nltk | 3.10.0-1 |
| Ubuntu Pro 14.04 LTS | nltk | no fix |
| Ubuntu Pro 16.04 LTS | nltk | no fix |
| Ubuntu Pro 18.04 LTS | nltk | no fix |
| Ubuntu Pro 20.04 LTS | nltk | no fix |
| Ubuntu Pro 22.04 LTS | nltk | no fix |
| Ubuntu Pro 24.04 LTS | nltk | no fix |
| Ubuntu Pro 26.04 LTS | nltk | no fix |