CVE-2026-7814
Fixed in a distro release EPSS <1%CVSS 4.8
Stored cross-site scripting (XSS) vulnerability in pgAdmin 4 Browser Tree and Explain Visualizer modules. User-controlled PostgreSQL object names (database, schema, table, column, etc.) were assigned to DOM elements via innerHTML, allowing crafted object names containing HTML markup to execute attacker-supplied JavaScript in the browser of any pgAdmin user who navigated to or executed EXPLAIN over the malicious object. Fix replaces innerHTML with textContent. This issue affects pgAdmin 4: before 9.15.
Products: pgadmin.org pgAdmin 4
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | pgadmin4 | 9.15 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | pgadmin4 | 9.15-r1 |
| Chainguard | pgadmin4 | 9.15-r0 |
| openSUSE Tumbleweed | pgadmin4 | 9.17-1.1 |