CVE-2026-77281
Fixed in a distro release EPSS <1%CVSS 6.5
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.
Products: caddyserver caddy
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/caddyserver/caddy/v2 | 2.11.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | caddy | 2.6.2-5+deb12u1 |
| Debian 13 | caddy | no fix |
| Debian 14 | caddy | 2.11.4-1 |
| Ubuntu Pro 24.04 LTS | caddy | no fix |
| Ubuntu Pro 26.04 LTS | caddy | no fix |