CVE-2026-77050
Fixed in a distro release EPSS <1%CVSS 5.3
An issue was discovered in Django 6.1 before 6.1.2, 6.0 before 6.0.9, and 5.2 before 5.2.18. `django.utils.translation.get_supported_language_variant()` is subject to a potential denial-of-service attack when processing many distinct, very long language codes, which are retained as keys in an in-memory cache and consume process memory. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Gleb Lizunov for reporting this issue.
Products: djangoproject django
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | python-django | 3:3.2.25-0+deb12u6 |
| Debian 13 | python-django | no fix |
| Debian 14 | python-django | no fix |
| SUSE Linux Enterprise Module for Package Hub 15 SP7 | python-Django | 4.2.11-150600.3.68.1 |
| Ubuntu 22.04 LTS | python-django | no fix |
| Ubuntu 24.04 LTS | python-django | no fix |
| Ubuntu 26.04 LTS | python-django | no fix |
| Ubuntu 26.10 | python-django | no fix |
| Ubuntu Pro 14.04 LTS | python-django | no fix |
| Ubuntu Pro 16.04 LTS | python-django | no fix |
| Ubuntu Pro 18.04 LTS | python-django | no fix |
| Ubuntu Pro 20.04 LTS | python-django | no fix |
| openSUSE Tumbleweed | python-Django | 6.1.2-1.1 |
| openSUSE Tumbleweed | python-Django4 | 4.2.30-6.1 |
| openSUSE Tumbleweed | python-Django5 | 5.2.18-1.1 |