CVE-2026-76228
Fixed upstream EPSS <1%CVSS 6.7
Renovate versions >=32.124.0 and before 42.68.5 (and Mend renovate-ce/renovate-ee before 13.3.0) contain a command injection vulnerability in Gradle Wrapper artifact handling. When Renovate processes Gradle Wrapper updates, it invokes a wrapper update command via a shell (e.g. /bin/sh -c ... ./gradlew :wrapper --gradle-distribution-url <value>). If an attacker supplies a malicious gradle-wrapper.properties whose distributionUrl contains shell command substitution syntax such as $(...), the shell evaluates it before Gradle parses the URL, resulting in arbitrary command execution in the Renovate runtime. Exploitation requires the attacker to introduce the malicious file into a repository that Renovate scans; the issue occurs even when allowScripts is disabled.
Products: renovatebot renovate, mend renovate-ce, mend renovate-ee-server, mend renovate-ee-worker
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | renovate | 42.68.5 |