Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-7482

Fixed in a distro release EPSS 2%CVSS 9.1

Ollama before 0.17.1 contains a heap out-of-bounds read vulnerability in the GGUF model loader. The /api/create endpoint accepts an attacker-supplied GGUF file in which the declared tensor offset and size exceed the file's actual length; during quantization in fs/ggml/gguf.go and server/quantization.go (WriteTo()), the server reads past the allocated heap buffer. The leaked memory contents may include environment variables, API keys, system prompts, and concurrent users' conversation data, and can be exfiltrated by uploading the resulting model artifact through the /api/push endpoint to an attacker-controlled registry. The /api/create and /api/push endpoints have no authentication in the upstream distribution. Default deployments bind to 127.0.0.1, but the documented OLLAMA_HOST=0.0.0.0 configuration is widely used in practice (large public-internet exposure observed).

Published 2026-05-04 · CVE record · OSV

Products: ollama

Fixed upstream

EcosystemPackageFixed in
Gogithub.com/ollama/ollama0.17.1

Distro releases

ReleasePackageFixed in
Chainguardk8sgpt0.4.33-r0
Chainguardmods1.8.1-r10
Chainguardmods1.8.1-r12
SUSE Linux Enterprise Server 16.0govulncheck-vulndb0.0.20260727T201416-160000.1.1
SUSE Linux Enterprise Server for SAP applications 16.0govulncheck-vulndb0.0.20260727T201416-160000.1.1
Wolfik8sgpt0.4.33-r0
Wolfimods1.8.1-r10
Wolfimods1.8.1-r12
openSUSE Leap 16.0govulncheck-vulndb0.0.20260727T201416-160000.1.1
openSUSE Tumbleweedollama0.33.1-1.1