CVE-2026-73627
Fixed in a distro release EPSS <1%CVSS 6.0
JupyterLab (pip package 'jupyterlab') versions >=4.1.0,<=4.5.9 and >=4.6.0,<=4.6.1 contain a plugin manager lock-rule enforcement bypass. Two server-side enforcement gaps allow an authenticated user to circumvent administrator lock rules by making direct requests to the /lab/api/plugins endpoint, enabling or disabling plugins that were locked — including child plugins of multi-plugin extensions and plugins locked via the 'lock all' mechanism. This can impact data integrity and bypass hardening or restrictions (e.g., download/upload limits) implemented through locked plugins. Fixed in versions 4.6.2 and 4.5.10.
Products: jupyterlab
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | jupyterlab | 4.6.2 |
| PyPI | jupyterlab | 4.5.10 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | jupyterlab | no fix |
| Debian 14 | jupyterlab | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 |
| Ubuntu 26.04 LTS | jupyterlab | no fix |
| Ubuntu 26.10 | jupyterlab | no fix |
| openSUSE Tumbleweed | python-jupyterlab | 4.5.10-1.1 |