CVE-2026-73626
Fixed in a distro release EPSS <1%CVSS 7.5
JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.
Products: jupyterlab
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | jupyterlab | 4.6.2 |
| PyPI | jupyterlab | 4.5.10 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 13 | jupyterlab | no fix |
| Debian 14 | jupyterlab | 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4 |
| Ubuntu 26.04 LTS | jupyterlab | no fix |
| Ubuntu 26.10 | jupyterlab | no fix |
| openSUSE Tumbleweed | python-jupyterlab | 4.5.10-1.1 |