CVE-2026-71513
Fixed in a distro release EPSS 1%CVSS 8.8
NLTK before 3.10.3 contains a remote code execution vulnerability in AllowlistUnpickler that validates only the pickle module string and not the global name, allowing attackers to resolve dotted names by attribute traversal to callables outside the allowlisted namespace. Attackers can craft untrusted transition-parser models that execute arbitrary commands when TransitionParser.parse loads the model through allowlisted_pickle_load.
Products: nltk
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | nltk | 3.10.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | nemo | 2.7.3-r27 |
| Chainguard | open-webui | 0.11.3-r1 |
| Debian 12 | nltk | no fix |
| Debian 13 | nltk | no fix |
| Debian 14 | nltk | 3.10.3-1 |
| Ubuntu 26.10 | nltk | no fix |
| Ubuntu Pro 14.04 LTS | nltk | no fix |
| Ubuntu Pro 16.04 LTS | nltk | no fix |
| Ubuntu Pro 18.04 LTS | nltk | no fix |
| Ubuntu Pro 20.04 LTS | nltk | no fix |
| Ubuntu Pro 22.04 LTS | nltk | no fix |
| Ubuntu Pro 24.04 LTS | nltk | no fix |
| Ubuntu Pro 26.04 LTS | nltk | no fix |
| Wolfi | open-webui | 0.11.3-r1 |
| openSUSE Tumbleweed | python-nltk | 3.10.3-1.1 |