CVE-2026-6959
Fixed in a distro release EPSS <1%CVSS 6.0
HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to arbitrary file read and write on the client host as the Nomad process user through a symlink attack. This vulnerability (CVE-2026-6959) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.
Products: HashiCorp Nomad, HashiCorp Nomad Enterprise
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/hashicorp/nomad | 1.11.0-rc.1.0.20260512123500-2a09fd62c238 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Ubuntu:18.04:LTS | nomad | no fix |
| Ubuntu:20.04:LTS | nomad | no fix |
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |