CVE-2026-6951
Fixed in a distro release EPSS <1%CVSS 9.8
Versions of the package simple-git before 3.36.0 are vulnerable to Remote Code Execution (RCE) due to an incomplete fix for [CVE-2022-25912](https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221) that blocks the -c option but not the equivalent --config form. If untrusted input can reach the options argument passed to simple-git, an attacker may still achieve remote code execution by enabling protocol.ext.allow=always and using an ext:: clone source.
Products: Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9, Red Hat JBoss Enterprise Application Platform 8, Red Hat JBoss Enterprise Application Platform Expansion Pack, Red Hat Process Automation 7
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | simple-git | 3.36.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | gemini-cli | 0.49.0-r3 |
| Chainguard | renovate | 43.170.15-r2 |
| Wolfi | renovate | 43.170.15-r2 |