CVE-2026-6739
Fixed in a distro release EPSS <1%CVSS 6.7
Mattermost versions 11.6.x <= 11.6.1, 11.5.x <= 11.5.4, 10.11.x <= 10.11.15, 10.11.x <= 10.11.16 fail to require system-level permission when patching protected default system roles, which allows authenticated users with delegated user-management permissions to escalate privileges by altering built-in role permissions via the role patch API.. Mattermost Advisory ID: MMSA-2026-00656
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.6.1 |
| Go | github.com/mattermost/mattermost-server | 11.5.5 |
| Go | github.com/mattermost/mattermost-server | 10.11.17 |
| Go | github.com/mattermost/mattermost-server | 10.11.17+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.5+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.6.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260501142004-99b73d4c4acf |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| SUSE Linux Enterprise Server 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |
| openSUSE Leap 16.0 | govulncheck-vulndb | 0.0.20260827T195228-160000.1.1 |