CVE-2026-67353
Fixed in a distro release EPSS <1%CVSS 5.3
guzzlehttp/guzzle versions before 7.15.1 contain a denial of service vulnerability in the CookieJar that accepts unlimited Set-Cookie header fields with no size restrictions. Attackers can return many large cookies from a malicious server, causing Guzzle to store excessive data in memory and generate oversized Cookie headers that fail in handlers or destination servers.
Products: guzzle
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Packagist | guzzlehttp/guzzle | 7.15.1 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | drupal-11.3 | 11.3.16-r0 |
| Chainguard | nextcloud-server-31 | 31.0.14-r5 |
| Chainguard | nextcloud-server-32 | 32.0.12-r6 |
| Chainguard | nextcloud-server-33 | 33.0.6-r8 |
| Chainguard | nextcloud-server-34 | 34.0.1-r9 |
| Chainguard | privatebin | 2.0.5-r1 |
| Debian 12 | guzzle | no fix |
| Debian 13 | guzzle | no fix |
| Debian 14 | guzzle | 7.15.1-1 |
| Ubuntu 24.04 LTS | guzzle | no fix |
| Ubuntu 26.04 LTS | guzzle | no fix |
| Ubuntu 26.10 | guzzle | no fix |
| Wolfi | nextcloud-server-32 | 32.0.12-r6 |
| Wolfi | nextcloud-server-33 | 33.0.6-r8 |