CVE-2026-6667
Fixed in a distro release EPSS <1%CVSS 4.3
PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in the admin_users parameter.
Products: pgbouncer
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | pgbouncer | 1.25.2-r0 |
| Chainguard | pgbouncer | 1.25.1-r1 |
| Chainguard | pgbouncer-doc | 1.25.2-r0 |
| Chainguard | pgbouncer-iamguarded-compat | 1.25.2-r0 |
| Debian 12 | pgbouncer | no fix |
| Debian 13 | pgbouncer | 1.24.1-1+deb13u2 |
| Debian 14 | pgbouncer | 1.25.2-1 |
| Ubuntu 16.04 LTS | pgbouncer | no fix |
| Ubuntu 18.04 LTS | pgbouncer | no fix |
| Ubuntu 20.04 LTS | pgbouncer | no fix |
| Ubuntu 22.04 LTS | pgbouncer | no fix |
| Ubuntu 24.04 LTS | pgbouncer | no fix |
| Ubuntu 25.10 | pgbouncer | no fix |
| Ubuntu 26.04 LTS | pgbouncer | no fix |
| Ubuntu 26.10 | pgbouncer | no fix |
| Wolfi | pgbouncer | 1.25.1-r1 |
| Wolfi | pgbouncer | 1.25.2-r0 |