CVE-2026-6664
Fixed in a distro release EPSS <1%CVSS 7.5
An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.
Products: pgbouncer
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | pgbouncer | 1.25.1-r1 |
| Chainguard | pgbouncer | 1.25.2-r0 |
| Chainguard | pgbouncer-doc | 1.25.2-r0 |
| Chainguard | pgbouncer-iamguarded-compat | 1.25.2-r0 |
| Debian 12 | pgbouncer | no fix |
| Debian 13 | pgbouncer | 1.24.1-1+deb13u2 |
| Debian 14 | pgbouncer | 1.25.2-1 |
| Ubuntu 16.04 LTS | pgbouncer | no fix |
| Ubuntu 18.04 LTS | pgbouncer | no fix |
| Ubuntu 20.04 LTS | pgbouncer | no fix |
| Ubuntu 22.04 LTS | pgbouncer | no fix |
| Ubuntu 24.04 LTS | pgbouncer | no fix |
| Ubuntu 25.10 | pgbouncer | no fix |
| Ubuntu 26.04 LTS | pgbouncer | no fix |
| Ubuntu 26.10 | pgbouncer | no fix |
| Wolfi | pgbouncer | 1.25.2-r0 |
| Wolfi | pgbouncer | 1.25.1-r1 |