CVE-2026-66393
Fixed in a distro release EPSS <1%CVSS 7.5
NLTK versions before 3.9.4 contain an unbounded recursion vulnerability in JSONTaggedDecoder.decode_obj() that allows attackers to cause denial of service by supplying deeply nested JSON structures. Attackers can craft JSON payloads exceeding the recursion limit to trigger an unhandled RecursionError that crashes the Python process.
Products: nltk
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | nltk | 3.9.4 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | apache-beam-python-3.11-sdk | 2.71.0-r8 |
| Chainguard | apache-beam-python-3.12-sdk | 2.71.0-r2 |
| Chainguard | apache-beam-python-3.13-sdk | 2.71.0-r2 |
| Chainguard | kubeflow-pipelines-visualization-server | 2.16.0-r3 |
| Chainguard | label-studio | 1.23.0-r1 |
| Chainguard | nemo | 2.7.2-r1 |
| Chainguard | open-webui | 0.8.12-r1 |
| Chainguard | open-webui | 0.8.12-r2 |
| Chainguard | py3.11-nltk | 3.9.4-r0 |
| Chainguard | py3.12-nltk | 3.9.4-r0 |
| Chainguard | py3.13-nltk | 3.9.4-r0 |
| Debian 12 | nltk | no fix |
| Debian 13 | nltk | no fix |
| Debian 14 | nltk | 3.10.0-1 |
| Ubuntu Pro 14.04 LTS | nltk | no fix |
| Ubuntu Pro 16.04 LTS | nltk | no fix |
| Ubuntu Pro 18.04 LTS | nltk | no fix |
| Ubuntu Pro 20.04 LTS | nltk | no fix |
| Ubuntu Pro 22.04 LTS | nltk | no fix |
| Ubuntu Pro 24.04 LTS | nltk | no fix |
| Ubuntu Pro 26.04 LTS | nltk | no fix |
| Wolfi | kubeflow-pipelines-visualization-server | 2.16.0-r3 |
| Wolfi | open-webui | 0.8.12-r1 |
| Wolfi | open-webui | 0.8.12-r2 |
| Wolfi | py3.11-nltk | 3.9.4-r0 |
| Wolfi | py3.12-nltk | 3.9.4-r0 |
| Wolfi | py3.13-nltk | 3.9.4-r0 |