CVE-2026-66053
Fixed in a distro release EPSS <1%CVSS 5.9
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603
Products: Apache Software Foundation Apache Thrift
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| PyPI | thrift | 0.24.0 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | thrift | no fix |
| Debian 13 | thrift | no fix |
| Debian 14 | thrift | 0.23.0-3 |
| Red Hat hummingbird 1 | perl-thrift | 0:0.24.0-0.1.hum1 |
| Red Hat hummingbird 1 | python3-thrift | 0:0.24.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift | 0:0.24.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift-devel | 0:0.24.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift-glib | 0:0.24.0-0.1.hum1 |
| Red Hat hummingbird 1 | thrift-qt | 0:0.24.0-0.1.hum1 |
| Ubuntu 16.04 LTS | python-thrift | no fix |
| Ubuntu 18.04 LTS | python-thrift | no fix |
| Ubuntu 20.04 LTS | thrift | no fix |
| Ubuntu 22.04 LTS | thrift | no fix |
| Ubuntu 24.04 LTS | thrift | no fix |
| Ubuntu 26.04 LTS | thrift | no fix |