Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-64831

Fixed in a distro release EPSS <1%CVSS 8.8

FFmpeg versions 8.0 through 8.1.2 contains a stack buffer overflow vulnerability in the Vulkan HEVC hardware decoder that allows remote attackers to overwrite return addresses and adjacent stack frames by supplying a crafted HEVC/H.265 bitstream. Attackers can embed a malicious vps_num_hrd_parameters value exceeding HEVC_MAX_SUB_LAYERS in any supported container format to overflow stack-allocated arrays in the vk_hevc_end_frame function, potentially achieving arbitrary code execution.

Published 2026-07-22 · CVE record · OSV

Products: FFMPEG

Distro releases

ReleasePackageFixed in
Chainguardeco-python-ffmpeg-8-minimal8.1.3-r0
Chainguardeco-python-ffmpeg-8-minimal-dev8.1.3-r0
Chainguardeco-python-ffmpeg-8-minimal-static8.1.3-r0
Chainguardffmpeg-8.00
Chainguardffmpeg-8.10
Chainguardffmpeg-fips-8.0no fix
Chainguardffmpeg-fips-8.0-devno fix
Chainguardffmpeg-fips-8.0-libavcodec62no fix
Chainguardffmpeg-fips-8.0-libavdevice62no fix
Chainguardffmpeg-fips-8.0-libavfilter11no fix
Chainguardffmpeg-fips-8.0-libavformat62no fix
Chainguardffmpeg-fips-8.0-libavutil60no fix
Chainguardffmpeg-fips-8.0-libavutil600
Chainguardffmpeg-fips-8.0-libswresample6no fix
Chainguardffmpeg-fips-8.0-libswscale9no fix
Chainguardffmpeg-fips-8.0-staticno fix
Chainguardffmpeg-fips-8.0-static0
Debian 14ffmpeg7:9.0.2-1
Ubuntu 26.10ffmpegno fix
Ubuntu Pro 14.04 LTSlibavno fix
Ubuntu Pro 26.04 LTSffmpeg7:8.0.1-3ubuntu2+esm4
Wolfiffmpeg-8.00
Wolfiffmpeg-8.10