Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-64649

Fixed in a distro release EPSS <1%CVSS 8.3

Next.js is a React framework for building full-stack web applications. In versions 14.1.1 through 15.5.20 and 16.0.0 through 16.2.10, when a Server Action forwards or redirects a request, an attacker can cause the server to send that outbound request to a malicious host (Server-Side Request Forgery). This requires the attacker's request to control Host-associated headers. In some configurations, it's also possible to obtain internal values that weaken middleware/proxy authorization. Applications that use Server Actions are affected when the incoming host header is not fixed to a trusted value. This typically occurs on custom servers, or on deployments not behind a proxy that pins the host. Managed hosting pins the host upstream and is not affected; next start and standalone output do the same from version 14.2 onward. This issue has been fixed in versions 15.5.21 and 16.2.11.

Published 2026-07-27 · CVE record · OSV

Products: vercel next.js

Fixed upstream

EcosystemPackageFixed in
npmnext15.5.21
npmnext16.2.11

Distro releases

ReleasePackageFixed in
Chainguardcadence-webno fix
Chainguardcommercial-chainloop-frontendno fix
Chainguardhomepage1.13.2-r8
Chainguardhomepage1.13.2-r9
Chainguardjitsucom-jitsu-console2.11.0-r30
Chainguardkeep-ui0.54.2-r1
Chainguardkeep-ui-fips0.54.2-r1
Chainguardlangfuse-22.95.12-r35
Chainguardlangfuse-33.224.1-r0
Chainguardlangfuse-3-compat3.225.7-r6
Chainguardlangfuse-3-worker3.224.1-r0
Chainguardlangfuse-fips-22.95.12-r38
Chainguardlangfuse-fips-33.224.1-r0
Chainguardlangfuse-fips-3-worker3.224.1-r0
Chainguardpeerdb-ui0.37.3-r1
Wolfijitsucom-jitsu-console2.11.0-r30
Wolfilangfuse-33.224.1-r0
Wolfilangfuse-3-compat3.225.7-r6
Wolfilangfuse-3-worker3.224.1-r0