CVE-2026-64642
Fixed in a distro release EPSS <1%CVSS 8.3
Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.
Products: vercel next.js
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | next | 16.2.11 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | commercial-chainloop-frontend | no fix |
| Chainguard | homepage | 1.13.2-r9 |
| Chainguard | homepage | 1.13.2-r8 |
| Chainguard | langfuse-3 | 3.224.1-r0 |
| Chainguard | langfuse-3-compat | 3.225.7-r6 |
| Chainguard | langfuse-3-worker | 3.224.1-r0 |
| Chainguard | langfuse-fips-3 | 3.224.1-r0 |
| Chainguard | langfuse-fips-3-worker | 3.224.1-r0 |
| Chainguard | peerdb-ui | 0.37.3-r1 |
| Wolfi | langfuse-3 | 3.224.1-r0 |
| Wolfi | langfuse-3-compat | 3.225.7-r6 |
| Wolfi | langfuse-3-worker | 3.224.1-r0 |