CVE-2026-63090
Fixed in a distro release EPSS <1%CVSS 8.8
ProFTPD before 1.3.9c and 1.3.10rc3 contains a heap-based buffer overflow vulnerability in the mod_sftp module that allows authenticated low-privilege attackers to achieve arbitrary code execution by sending crafted SFTP packet fragments exceeding the 16 KB reassembly buffer in the fxp.c component. Attackers can supply oversized fragments to trigger an incorrectly conditioned reallocation, corrupt pool freelist metadata, overwrite the root_fs BSS global pointer to reference a fake filesystem struct, and redirect pr_fsio_stat() to system() via a crafted RENAME request.
Products: ProFTPD
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | proftpd-dfsg | no fix |
| Debian 13 | proftpd-dfsg | 1.3.8.c+dfsg-4+deb13u3 |
| Debian 14 | proftpd-dfsg | 1.3.9c~dfsg-1 |
| Ubuntu 16.04 LTS | proftpd-dfsg | no fix |
| Ubuntu 18.04 LTS | proftpd-dfsg | no fix |
| Ubuntu 20.04 LTS | proftpd-dfsg | no fix |
| Ubuntu 22.04 LTS | proftpd-dfsg | no fix |
| Ubuntu 24.04 LTS | proftpd-dfsg | no fix |
| Ubuntu 26.04 LTS | proftpd-dfsg | no fix |
| Ubuntu 26.10 | proftpd-dfsg | no fix |