CVE-2026-59985
Fixed in a distro release EPSS <1%CVSS 5.5
OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. OpenEXR versions 3.2.0 through 3.2.10, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13 are vulnerable on ILP32 builds to a heap out-of-bounds read. The issue occurs when a crafted RLE-compressed EXR causes the 64-bit unpacked size to truncate before allocation in OpenEXRCore decoding.c and unpack_32bit() reads beyond the resulting buffer, allowing denial of service. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.
Products: AcademySoftwareFoundation openexr
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | openexr | no fix |
| Debian 13 | openexr | no fix |
| Debian 14 | openexr | 3.4.14-0.1 |
| SUSE Linux Enterprise Server 16.0 | openexr | 3.2.2-160000.10.1 |
| SUSE Linux Enterprise Server for SAP applications 16.0 | openexr | 3.2.2-160000.10.1 |
| Ubuntu 26.10 | openexr | no fix |
| Ubuntu Pro 16.04 LTS | openexr | no fix |
| Ubuntu Pro 18.04 LTS | openexr | no fix |
| Ubuntu Pro 20.04 LTS | openexr | no fix |
| Ubuntu Pro 22.04 LTS | openexr | no fix |
| Ubuntu Pro 24.04 LTS | openexr | no fix |
| Ubuntu Pro 26.04 LTS | openexr | no fix |
| openSUSE Leap 16.0 | openexr | 3.2.2-160000.10.1 |
| openSUSE Tumbleweed | openexr | 3.4.14-1.1 |
| openSUSE Tumbleweed | python-OpenEXR | 3.4.16-1.1 |