CVE-2026-59685
Fixed in a distro release EPSS <1%CVSS 7.5
Out-of-bounds Write vulnerability in Apache HTTP Server on Windows while processing paths with 8.3 names that may grow when expanded. This issue affects Apache HTTP Server: from 2.4.0 through 2.4.68.
Products: Apache Software Foundation Apache HTTP Server
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.21 | apache2 | 2.4.69-r0 |
| Alpine 3.22 | apache2 | 2.4.69-r0 |
| Alpine 3.23 | apache2 | 2.4.69-r0 |
| Alpine 3.24 | apache2 | 2.4.69-r0 |
| Debian 12 | apache2 | no fix |
| Debian 13 | apache2 | no fix |
| Debian 14 | apache2 | no fix |
| Ubuntu 22.04 LTS | apache2 | no fix |
| Ubuntu 24.04 LTS | apache2 | no fix |
| Ubuntu 26.04 LTS | apache2 | no fix |
| Ubuntu Pro 14.04 LTS | apache2 | no fix |
| Ubuntu Pro 16.04 LTS | apache2 | no fix |
| Ubuntu Pro 18.04 LTS | apache2 | no fix |
| Ubuntu Pro 20.04 LTS | apache2 | no fix |