CVE-2026-57452
Fixed in a distro release EPSS <1%CVSS 5.5
Vim is an open source, command line text editor. Prior to 9.2.0671, when Vim opens a file encrypted with the VimCrypt~04! or VimCrypt~05! method (xchacha20poly1305, requires the +sodium feature) whose body is shorter than a single libsodium secretstream header, an unsigned length calculation underflows and a subsequent decryption call reads far past the end of the input buffer, crashing Vim. This vulnerability is fixed in 9.2.0671.
Products: vim
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Alpine 3.23 | vim | 9.2.0854-r0 |
| Debian 12 | vim | no fix |
| Debian 13 | vim | no fix |
| Debian 14 | vim | 2:9.2.0782-1 |
| Red Hat hummingbird 1 | vim | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-X11 | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-common | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-data | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-default-editor | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-enhanced | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-filesystem | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | vim-minimal | 0:9.2.725-1.hum1 |
| Red Hat hummingbird 1 | xxd | 0:9.2.725-1.hum1 |
| Ubuntu 22.04 LTS | vim | 2:8.2.3995-1ubuntu2.33 |
| Ubuntu 24.04 LTS | vim | 2:9.1.0016-1ubuntu7.17 |
| Ubuntu 25.10 | vim | 2:9.1.0967-1ubuntu6.8 |
| Ubuntu 26.04 LTS | vim | 2:9.1.2141-1ubuntu4.6 |
| Ubuntu Pro 14.04 LTS | vim | 2:7.4.052-1ubuntu3.1+esm30 |
| Ubuntu Pro 16.04 LTS | vim | 2:7.4.1689-3ubuntu1.5+esm36 |
| Ubuntu Pro 18.04 LTS | vim | 2:8.0.1453-1ubuntu1.13+esm21 |
| Ubuntu Pro 20.04 LTS | vim | 2:8.1.2269-1ubuntu5.32+esm9 |