CVE-2026-5740
Fixed in a distro release EPSS <1%CVSS 7.5
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to properly validate msgpack-encoded WebSocket frames before memory allocation which allows an unauthenticated remote attacker to crash the server process and cause a full service outage for all users via a crafted binary WebSocket message sent to the public WebSocket endpoint.. Mattermost Advisory ID: MMSA-2026-00647
Products: Mattermost
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| Go | github.com/mattermost/mattermost-server | 11.6.1 |
| Go | github.com/mattermost/mattermost-server | 11.5.4 |
| Go | github.com/mattermost/mattermost-server | 11.4.5 |
| Go | github.com/mattermost/mattermost-server | 10.11.15 |
| Go | github.com/mattermost/mattermost-server | 10.11.15+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.4.5+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.5.4+incompatible |
| Go | github.com/mattermost/mattermost-server | 11.6.1+incompatible |
| Go | github.com/mattermost/mattermost-server/v5 | no fix |
| Go | github.com/mattermost/mattermost-server/v6 | no fix |
| Go | github.com/mattermost/mattermost/server/v8 | 8.0.0-20260410202636-17939826efa2 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| openSUSE:Leap 16.0 | govulncheck-vulndb | 0.0.20260723T184607-160000.1.1 |