CVE-2026-56698
Fixed upstream EPSS <1%CVSS 6.1
Nuxt versions 4.0.0 before 4.4.7 and 3.x before 3.21.7 fail to validate script-capable URLs in the navigateTo open option, allowing client-side script execution. Attackers can supply javascript: URLs through the open parameter to execute arbitrary scripts in the application's origin when user-controlled input is passed to navigateTo.
Products: nuxt
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | nuxt | 4.4.7 |
| npm | nuxt | 3.21.7 |