Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-56340

Fixed upstream EPSS <1%CVSS 8.8

vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

Published 2026-06-20 · CVE record · OSV

Products: vllm, Red Hat AI Inference Server, Red Hat Enterprise Linux AI (RHEL AI) 3, Red Hat OpenShift AI (RHOAI)

Fixed upstream

EcosystemPackageFixed in
PyPIvllm0.13.0

Distro releases

ReleasePackageFixed in
Chainguardtritonserver-backend-vllm-cuda-12.9no fix