Patchwire CVEs, their patch status, and feeds to follow them

CVE-2026-56317

Fixed upstream EPSS <1%CVSS 2.3

Nuxt before 4.4.7 (and the 3.x branch before 3.21.7) contains a cross-site scripting vulnerability in the NoScript component that writes slot content to innerHTML without escaping. Attackers can inject malicious scripts through untrusted data in NoScript slots, such as route.query parameters, which execute in the document context when the noscript tag is implicitly closed by script tags.

Published 2026-06-20 · CVE record · OSV

Products: nuxt

Fixed upstream

EcosystemPackageFixed in
npmnuxt4.4.7
npmnuxt3.21.7