CVE-2026-56091
No fix known EPSS <1%CVSS 8.2
When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass. This vulnerability is similar to https://www.cve.org/CVERecord?id=CVE-2020-1957 https://www.cve.org/CVERecord , except that it affects the `shiro-guice` module instead of the `shiro-spring` module. This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context. Upgrade to version 3.0.0 or later, which fixes the issue.
Products: Apache Software Foundation Apache Shiro
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | shiro | no fix |
| Debian 13 | shiro | no fix |
| Debian 14 | shiro | no fix |
| Ubuntu 20.04 LTS | shiro | no fix |
| Ubuntu 22.04 LTS | shiro | no fix |
| Ubuntu 25.10 | shiro | no fix |
| Ubuntu 26.04 LTS | shiro | no fix |
| Ubuntu 26.10 | shiro | no fix |
| Ubuntu Pro 16.04 LTS | shiro | no fix |
| Ubuntu Pro 18.04 LTS | shiro | no fix |
| Ubuntu Pro 24.04 LTS | shiro | no fix |