CVE-2026-55969
Fixed in a distro release EPSS 1%CVSS 8.7
Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Products: Apache Software Foundation Apache Thrift
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Debian 12 | thrift | no fix |
| Debian 13 | thrift | no fix |
| Debian 14 | thrift | no fix |
| Red Hat hummingbird 1 | jaeger | 0:2.20.0-0.5.hum1 |
| Red Hat hummingbird 1 | tempo2.10 | 0:2.10.7-0.2.hum1 |
| Red Hat hummingbird 1 | tempo3.0 | 0:3.0.2-0.2.hum1 |
| Ubuntu 20.04 LTS | thrift | no fix |
| Ubuntu 22.04 LTS | thrift | no fix |
| Ubuntu 24.04 LTS | thrift | no fix |
| Ubuntu 26.04 LTS | thrift | no fix |
| Ubuntu 26.10 | thrift | no fix |
| openSUSE Tumbleweed | thrift | 0.24.0-1.1 |