CVE-2026-55697
Fixed upstream EPSS <1%CVSS 7.5
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.
Products: pnpm
Fixed upstream
| Ecosystem | Package | Fixed in |
|---|---|---|
| npm | pnpm | 10.34.2 |
| npm | pnpm | 11.5.3 |
Distro releases
| Release | Package | Fixed in |
|---|---|---|
| Chainguard | pnpm-11.4 | no fix |
| Chainguard | pnpm-stage0 | no fix |
| Wolfi | pnpm-stage0 | no fix |